G2 Crowd User in Internet

Installation

about 2 years ago

What do I need to install Sisense?

Vendor Responses

Response by Sisense

over 1 year ago

Supported Web Browsers - The Sisense Web Application runs in the following HTML5 supported browsers:

Internet Explorer 10 and up

Google Chrome

Firefox

Safari version 7 and up

The Sisense Web Application also works in mobile phone and tablet browsers that support HTML5.

Supported Operating Systems - ElastiCube Server and ElastiCube Manager can be installed on the following 64-bit operating systems:

Windows 7 and up

Windows Server 2008 R2 and up