G2 Crowd User

Requirements

about 2 years ago

What are the system requirements?

Vendor Responses

Response by Kickserv

over 1 year ago

Since Kickserv is a fully managed web-based application, there is nothing you need to download or install. All you need is a web browser.Chrome, Firefox, or Safari will work the best. You can use Internet Explorer 9+ but it is not recommended. We work on any MAC or PC and most all Tablets and Smartphones using their mobile web browser.